SQL Server error code
SQL Server error 3951
SQL Server raises error 3951 at severity 16, which marks a problem with the query or data that you can correct.
Transaction failed in database '%.*ls' because the statement was run under snapshot isolation but the transaction did not start in snapshot isolation. You cannot change the isolation level of the transaction to snapshot after the transaction has started unless the transaction was originally started under snapshot isolation level.
| Msg | 3951 |
|---|---|
| Severity | 16 |
| Group | 3000–3999 |