Seaquel
SQL Server error code

SQL Server error 3954

SQL Server raises error 3954 at severity 16, which marks a problem with the query or data that you can correct.

Snapshot isolation transaction failed to start in database '%.*ls' because the ALTER DATABASE command that disallows snapshot isolation had started before this transaction began. The database is in transition to OFF state. You will either need to change the isolation level of the transaction or re-enable the snapshot isolation in the database.
Msg3954
Severity16
Group3000–3999

Source: Database Engine events and errors