SQL Server error code
SQL Server error 3989
SQL Server raises error 3989 at severity 16, which marks a problem with the query or data that you can correct.
New request is not allowed to start because it should come with valid transaction descriptor.
| Msg | 3989 |
|---|---|
| Name | XACT_UNSUPPORT_PARALLEL_TRAN3 |
| Severity | 16 |
| Group | 3000–3999 |
What it means
This error occurs when you execute a distributed query that joins multiple tables hosted by remote instances of SQL Server while the XACT_ABORT session setting is ON. An error message similar to the following is reported to the user: