SQL Server error code
SQL Server error 7988
SQL Server raises error 7988 at severity 16, which marks a problem with the query or data that you can correct.
System table pre-checks: Object ID %d. Loop in data chain detected at %S_PGID. Check statement terminated due to unrepairable error.
| Msg | 7988 |
|---|---|
| Name | DBCC2_PRE_CHECKS_CHAIN_LOOP_DETECTED |
| Severity | 16 |
| Group | 7000–7999 |
What it means
The first phase of a DBCC CHECKDB is to do primitive checks on the data pages of critical system tables. If any errors are found, they cannot be repaired; therefore, DBCC CHECKDB terminates immediately. A page linkage loop has been detected on page P_ID. A page linkage loop occurs when the next page pointers from a page eventually return to the page.