Seaquel
SQL Server error code

SQL Server error 4064

SQL Server raises error 4064 at severity 11, which marks a problem with the query or data that you can correct.

Cannot open user default database. Login failed.
Msg4064
NameDB_UFAIL_FATAL
Severity11
Group4000–4999

What it means

The SQL Server login was unable to connect to SQL Server, either due to permission issues with a database user associated with the login in the default database, or a problem with its default database.

Source: Database Engine events and errors