SQL Server error code
SQL Server error 4064
SQL Server raises error 4064 at severity 11, which marks a problem with the query or data that you can correct.
Cannot open user default database. Login failed.
| Msg | 4064 |
|---|---|
| Name | DB_UFAIL_FATAL |
| Severity | 11 |
| Group | 4000–4999 |
What it means
The SQL Server login was unable to connect to SQL Server, either due to permission issues with a database user associated with the login in the default database, or a problem with its default database.