SQL Server error code
SQL Server error 2596
SQL Server raises error 2596 at severity 16, which marks a problem with the query or data that you can correct.
The repair statement was not processed. The database cannot be in read-only mode.
| Msg | 2596 |
|---|---|
| Name | DBCC_DATABASE_IN_READ_ONLY_MODE |
| Severity | 16 |
| Group | 2000–2999 |
What it means
This message indicates that the database is in read-only mode. Repairs are not possible when a database is in read-only mode.