SQL Server error code
SQL Server error 1205
SQL Server raises error 1205 at severity 13, which marks a problem with the query or data that you can correct.
Transaction (Process ID %d) was deadlocked on %.*ls resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
| Msg | 1205 |
|---|---|
| Name | LK_VICTIM |
| Severity | 13 |
| Group | 1000–1999 |
What it means
Resources are accessed in conflicting order on separate transactions, causing a deadlock. For example:
Transaction1 updates Table1.Row1, while Transaction2 updates Table2.Row2 - Transaction1 tries to update Table2.Row2 but is blocked because Transaction2 hasn't yet committed and hasn't released its locks - Transaction2 now tries to update Table1.Row1 but is blocked because Transaction1 hasn't committed and hasn't released its locks - A deadlock occurs because Transaction1 is waiting for Transaction2 to complete, but Transaction2 is waiting for Transaction1 to complete.